Jump to content
OzarkAnglers.Com Forum
Sign in to follow this  
Duke 59

Prairie Creek Area Today

Recommended Posts

Went out today from noon to 5 hoping to find some stripers in the prairie creek area.  Started off bad as I was going to get some gas at the marina....but didn't realize it was closed.  I think the sign on the door said it was closed for the holidays from Dec 22 to Jan 8th.  I have a hard time understanding how they can be closed for that long.  There are hundred of boat owners renting slips from them, there is a lot of traffic using the boat ramp, yet they close.  I know I just moved here this year, so I'm still learning how things work, but it seems to me that the marina is there to serve this public lake and should have an obligation to have some open hours.

I thought I had enough gas to go where I planned, so I started out and went over to Coose.  Made it all the way to the back of the arm...didn't see any fish on the graph, no bait balls and no birds.  When I got to the back I did see another boat waving at me.  I went over and they were having battery problems and needed a tow.  I gladly pulled them back to the prairie creek boat ramp....definitely would want help if I needed it.

Now my gas level is getting lower so I headed over to the islands and again saw very little activity on the graph, so headed back home.

Water temps were around 42 in the shallow areas in the back of Avoca, Prairie Creek and Coose....in open deep water it was around 45/46.  I did mark quite a few bass or crappie around the marina.

Great weather and time on the lake.....just no fish.....and I didn't run out of gas....but will if I go out again.

Greg

 

Share this post


Link to post
Share on other sites

Good on You for helping someone...take some with you...fill the lawn mower can up...and take it to boat

bring a bunch of gas...and go way up the river this time of year though

Share this post


Link to post
Share on other sites

I definitely did not see any shad shallow.  In fact even when i was marking some fish, they didn't seem to be on bait.  I guess I was just looking at the wrong places.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.