Jump to content
OzarkAnglers.Com Forum
eyedabassman

No running lights on Trailer problem?

Recommended Posts

I am at my wits end! My running lights went out half way home one night! I did test all my fuses and they are ok, tested pig tail and that seems good so my guess it is the trailer? I have electric brakes on the trailer. My turn signals work and I have tail lights just no marker lights! And the brakes lock up when I back up so I have this tool to put in the trailer to release the brakes. I think it is a Marine Master trailer! Any help would be great?

Share this post


Link to post
Share on other sites

I have a Marine master myself.  Hopefully you still have the trailer booklet, it should have instructions on how to reset the deal that causes the brakes to activate when you backup.  If not, you can give Marine Master a call.

If all else fails, JWM trailer in Reed Springs do great work, I have had my trailer in there a couple of times, always been satisfied and they are very reasonable.  

https://www.mapquest.com/us/missouri/jwm-trailer-sales-inc-357631164

Share this post


Link to post
Share on other sites

So everything is fine except the marker lights, correct?

They typically are just a single wire tapped into the brown (tail light) wire, and they ground via the trailer frame.   Since they are all out I'd say your ground connection to the trailer frame is bad (white wire).   

Share this post


Link to post
Share on other sites

I don’t know what kind of tow vehicle you have but I had the same problem with mine a few months back and found out it was a small fuse in an out of the way compartment in my Honda Pilot. Just a thought.

Share this post


Link to post
Share on other sites
5 hours ago, eyedabassman said:

I am at my wits end! My running lights went out half way home one night! I did test all my fuses and they are ok, tested pig tail and that seems good so my guess it is the trailer? I have electric brakes on the trailer. My turn signals work and I have tail lights just no marker lights! And the brakes lock up when I back up so I have this tool to put in the trailer to release the brakes. I think it is a Marine Master trailer! Any help would be great?

your marker lights and tail lights work off the same wire.  get a test light and see if there is juice going to the maker lights.  if so, you may just need new bulbs.

bo

 

Share this post


Link to post
Share on other sites

Had a similar problem at one point- drove me crazy.  Ended up being a random fuse under the hood, not one from inside the cab like you would think. Good luck 

Share this post


Link to post
Share on other sites
5 hours ago, Quillback said:

I have a Marine master myself.  Hopefully you still have the trailer booklet, it should have instructions on how to reset the deal that causes the brakes to activate when you backup.  If not, you can give Marine Master a call.

If all else fails, JWM trailer in Reed Springs do great work, I have had my trailer in there a couple of times, always been satisfied and they are very reasonable.  

https://www.mapquest.com/us/missouri/jwm-trailer-sales-inc-357631164

Yes I have that little tool that goes into the slot to release the brakes, if that is what you mean?

Share this post


Link to post
Share on other sites
5 hours ago, fishinwrench said:

So everything is fine except the marker lights, correct?

They typically are just a single wire tapped into the brown (tail light) wire, and they ground via the trailer frame.   Since they are all out I'd say your ground connection to the trailer frame is bad (white wire).   

Yes turn signals work, brake lights  work just no marker lights!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use.